Anyone try the insulight flashing insulator?

I bought from Valley Vet and just got around to putting it on the fence, and it doesn’t seem to work. It’s an insulator, right?, so I would think my electric tape would go through the insulator part. There is no metal in the insulator to transmit a charge to the light. The wording on the instructions is odd “put the wire between (I can’t remember)” when the description is “Works on wire, braided wire, or electrical tape and can attach to steel posts, T-posts, or wooden posts.” It sounds like maybe the wire is supposed to go between the light and the front of the insulator. I don’t know if wire would go through the tiny opening, but tape certainly won’t. Any advice?

I also find it interesting that shaking the insulator (right out of the box) makes the light flash. I would’ve thought the electricity was needed to make it light up.

I can not imagine how it works but looking on their website shows you installing the fencing (tape/wire) like you would think, like any other insulator.

I noticed with the photos of wire being used the wire is down even with the back of light itself. Is there some contact (metal) on the inside of the insulator at the light?

Photo from their website to show what I mean about the wire being right behind the light:

The photo you posted looked like the wire might be in the “between” area from the directions. But this photo shows it clearly in the insulator area. Interesting how in every photo, the insulator is upside down. No, no metal at all in the insulator area.


I so wanted this to work! I bought one, installed it per directions —like yours it flashed in the box, so battery good. After installation --nothing. I reinstalled at various places: metal poles, wood poles, no poles. I used my old fence tester to make sure I had a strong charge (I did). Nothing worked. I sent it back and they sent another. Same problem. Just wouldn’t work. Yet, if I held the fence tester to the wire, AND included the sensor --it did flash. If I tapped it, it flashed. I tried thicker wire --nothing. Honestly, I tried everything. Sent it back.

1 Like