Hiding public profile also hides PM button?

It’s come to my attention that people can’t figure out how to PM me. I do have PMs enabled (see screenshot of my settings) and I do receive them, but if you click on my username it seems you don’t see the convenient little “Message” button (see screenshot of @Moderator_1’s) because my public profile is hidden. I think people have to manually go to messages, create a new message, and type in my username. Is there a way to make the “Message” button show up even if people’s public profile is hidden? Thanks!

If you don’t want your profile public, another option for other users to PM you can be accessed when they click the reply button to your post in a thread. When the message composition screen pops up at the bottom of the page, they click the reply arrow from the upper left corner of the pop-up box (next to the title of the thread they’re replying to).

They can select “New Message” reply option there, which will allow another user to send their message to you as a PM.

Nope. That’s something you give up when you make your profile private.

People can PM you from the PM window, or from the reply window (as Mod1 describes), or from the “flag a post” dialogue box.

image

1 Like

Thanks, that’s good to know but kind of obscure!

Oh wow! I did not realize that. Good information.

1 Like

I don’t really feel like I’m giving anything up. Just wondering if there was a way to make it more convenient for other people since two have posted that they couldn’t figure out how to PM me in the past few days. (I got the message indirectly anyway since they tagged me in their post, so it doesn’t matter very much.)

Not about PMs, but there is no way to mute or ignore a member with a hidden profile.
Or am I overlooking something?

Go to your preferences>users

Enter desired poster name to ignore or muted category

Save changes

3 Likes